金融动态-申博太阳城娱乐_太阳城娱乐网址_太阳城线上官网

主力强攻突破压力,MACD早有埋伏?配合使用成功率高(源码)

阅读:   时间: 2017/11/14 10:33:04  【打印】  【关闭

指标的使用很简单,接触一个新的指标,不知道怎么使用?你利用这个指标,结合股票历史的走势,但个股的规律和信号出现的规律,都明白了。

在技术参考的层面上,作为一个判断性的工具,它的使用可以配合自己的经验,在看盘和做买卖决策上提供一定的帮助。

所以说即便再利用率很高,我们平时使用的软件,像通达信、大智慧、东方财付通等。没有一定的或者自身自带的技术指标函数,再说指标只是参考,但它在一定程度上是可以被利用的。

在指标的演化过程中,macd的利用率非常高,这类的设计也层出不穷,虽然函数很容易写,对于这些指标的,函数都是公开的,但是唯一区别的就是一个经验的融合,怎样才能把指标的表达和,个人经验相结合在一起?这个才是指标的重要性。

重点说一下今天的这个macd副图的演化过程,函数运算还是传统类的,只是在表达方面,做了一个颜色显示的优化。

还有在金叉和死叉发生的时候,增加了一个箭头指示效果,这个可以从图片中看得到。

使用安装时可以结合传统的MACD进行一个综合的对比,哪个看的清晰,或者更能表达信号的出入。就使用哪一个。

下方为源码公开部份的完整部分,复制写入就可以,这个是副图就不用强调了吧?近期的很多添加不成功,是因为在选指标和选股类别上混淆了,这个是副图。

DIFIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEAEA1:=EMA(DIFIF1,9);

MACD1:=2*(DIFIF1-DEAEA1),STICK;

MACD2:=EMA(MACD1,3);

STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,0),COLORRED;

STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,0),COLORGREEN;

STICKLINE(MACD1

STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;

DIFIF1,COLOR33FF33,LINETHICK2;

DEAEA1,COLORYELLOW,LINETHICK2;

MACD:MACD1,NODRAW,COLORMAGENTA;

强:IF(DIFIF1>=DEAEA1,DIFIF1,DRAWNULL),COLORRED,LINETHICK2;

弱:IF(DEAEA1>=DIFIF1,DEAEA1,DRAWNULL),COLORFF9900,LINETHICK2;

DRAWICON(CROSS(DIFIF1,DEAEA1),DIFIF1+0.1,1);

DRAWICON(CROSS(DEAEA1,DIFIF1),-0.5,2);


演化版本的指标,其做用就是在显示和不同,可能更直观一些,当然这要看个人的使用习惯了,还有就是一个技术模版的组合设定,各有各的爱好。DRAWTEXT(CROSS(DIFIF1,DEAEA1),DIFIF1,'○'),LINETHICK2, COLORYELLOW;


Top